05 sti into 06 sti strut problem

stueyknuxx
Learner Driver
Posts: 8
Joined: Fri Apr 21, 2017 8:23 pm

05 sti into 06 sti strut problem

Postby stueyknuxx » Sun Nov 26, 2017 4:19 pm

Hey guys

So my 06 sti i bought came with coilovers which I don't like and i want to go back to stock suspension with some lowered springs for a bit more comfort.
So i ripped out the front coilover last night only to find the 2nd hand 05 sti struts i have don't fit. the top hat bolts aren't far enough apart. So that was annoying. From what I could kinda find on the net is I must of got a set of early 05 sti struts before they changed the wheel hub to 114.3 and so the tops changed when Subaru brought out the hawkeye shape ?
Anyone know if thats right ?

Looking at replacing the strut top mounts with the sti group n mounts so that it will fit, and looking at a few of the pics and its hard to see but it doesn't look like the dust covers can go back on. The pics look like its just the rubber ? Like its missing the slotted metal part as you can see in my pic attached. Can anyone shed some light on this ??

And possibly shed some light on my first paragraph about them not fitting in the first place ?

I've attached a link to get a good 360 degree view on the Group N mount

https://www.youtube.com/watch?v=Ee5aRsxOHOA

Thanks guys

Image

User avatar
KevO-954
Fireblade/WRX Driver
Fireblade/WRX Driver
Posts: 3916
Joined: Fri Oct 21, 2005 8:18 pm
Location: Melbourne, Eastern suburbs

Re: 05 sti into 06 sti strut problem

Postby KevO-954 » Sun Nov 26, 2017 10:54 pm

Are you sure? Not that I am an expert but I thought the top hats would all be the same in the GD series including WRX and STi right from 2002 to 2007 irrespective of them going on a 114.3 hub or a 5x100 hub? I think you must have incorrect top hats fitted to the struts. hmmm

stueyknuxx
Learner Driver
Posts: 8
Joined: Fri Apr 21, 2017 8:23 pm

05 sti into 06 sti strut problem

Postby stueyknuxx » Mon Nov 27, 2017 7:58 am

KevO-954 wrote:Are you sure? Not that I am an expert but I thought the top hats would all be the same in the GD series including WRX and STi right from 2002 to 2007 irrespective of them going on a 114.3 hub or a 5x100 hub? I think you must have incorrect top hats fitted to the struts. hmmm

That’s what I originally thought aswell mate, definitely possible someone swapped them for a diff Subaru top hat. Definitely the front bolt pattern is too small but the rears are fine.
I got them interstate from wreckers, f**ks haha ahwell I’ll get group N’s


Sent from my iPhone using Tapatalk

hy_rpm
Learner Driver
Posts: 1
Joined: Thu Feb 16, 2006 9:00 am

Re: 05 sti into 06 sti strut problem

Postby hy_rpm » Sat Dec 02, 2017 9:07 pm

stueyknuxx wrote:Hey guys

So my 06 sti i bought came with coilovers which I don't like and i want to go back to stock suspension with some lowered springs for a bit more comfort.
So i ripped out the front coilover last night only to find the 2nd hand 05 sti struts i have don't fit. the top hat bolts aren't far enough apart. So that was annoying. From what I could kinda find on the net is I must of got a set of early 05 sti struts before they changed the wheel hub to 114.3 and so the tops changed when Subaru brought out the hawkeye shape ?
Anyone know if thats right ?

Looking at replacing the strut top mounts with the sti group n mounts so that it will fit, and looking at a few of the pics and its hard to see but it doesn't look like the dust covers can go back on. The pics look like its just the rubber ? Like its missing the slotted metal part as you can see in my pic attached. Can anyone shed some light on this ??

And possibly shed some light on my first paragraph about them not fitting in the first place ?

I've attached a link to get a good 360 degree view on the Group N mount

https://www.youtube.com/watch?v=Ee5aRsxOHOA

Thanks guys

Image

I got a pair of 05 sti strut tops if you want and in nsw pm me
I tryed to put the sti struts in my 03 wrx but i think the sti struts were for 5x114 hubs so the bolt holes at the hub were further apart
End up just using the pink sti springs in my03 struts so have complete my05 struts spare minus springs
The top hats were identical even bolted them in the car but the bottom wouldnt line up

Return to “Wheels, Tyres, Brakes and Suspension”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests