Unable to boost past 15psi

Project_Dx
Learner Driver
Posts: 17
Joined: Mon Aug 31, 2015 1:15 pm

Unable to boost past 15psi

Postby Project_Dx » Thu Feb 02, 2017 12:02 am

Hey guys,

My car is tuned for 20psi max boost but for some reason I'm only able to hit 15psi max. Reading off my boost gauge.

I've had some problems with my Grimmspeed EBCS in the past and replaced it with a brand new one. It was boosting properly initially but now seems to be playing up again?

Connections to the EBCS seems alright. To be sure i cable tied the connections too. Now i did notice a little oil on the turbo outlet nipple. Is 15psi just from my wastegate actuator?

Any help would be appreciated. Thanks

specr
Probationary Driver
Posts: 98
Joined: Tue Sep 27, 2016 11:22 am
Location: Northern Beaches NSW

Re: Unable to boost past 15psi

Postby specr » Thu Feb 02, 2017 7:05 am

I've heard bad things about the grimspeed 3 port. Try a pierburg?
MY13 STI Spec R - BLACK

ryano
Impreza WRX Driver
Posts: 271
Joined: Thu Aug 19, 2010 9:12 pm

Re: Unable to boost past 15psi

Postby ryano » Thu Feb 02, 2017 10:08 am

im having the same issue with my 3 port which is a mac valve and i think the grimmspeed is a mac valve too, at first i thought it was the hot weather but dropping 5 psi is a fair bit, wastegate pressure is usually ~8 psi but you may have a 1 bar actuator (14.7 psi)

Project_Dx
Learner Driver
Posts: 17
Joined: Mon Aug 31, 2015 1:15 pm

Re: Unable to boost past 15psi

Postby Project_Dx » Thu Feb 02, 2017 10:15 am

I've actually bought a Pierburg EBCSand plugged it in. It was still doing the same thing.

Since it was doing the same thing, I swapped the Grimmspeed back in because my car was tuned for it. I have a stock actuator (MY12 WRX), so do you think it would be a 1 bar version?

ryano
Impreza WRX Driver
Posts: 271
Joined: Thu Aug 19, 2010 9:12 pm

Re: Unable to boost past 15psi

Postby ryano » Thu Feb 02, 2017 11:20 am

stock one shouldn't be 1 bar, you can check by connecting a hose from the turbo nipple to actuator

Andy05
Probationary Driver
Posts: 64
Joined: Fri Jan 09, 2015 7:00 pm

Re: Unable to boost past 15psi

Postby Andy05 » Thu Feb 02, 2017 12:07 pm

I would have expected gate pressure stock would be more likely around 7-10psi (note this is only talking from what I know from other modified turbo cars not specific to your model wrx so I could be wrong). It definitely wouldn't be 15 though (that's way too high for a stock car).

Have you considered it may not be the boost control, your ECU could be sensing knock and pulling boost?

Andy05
Probationary Driver
Posts: 64
Joined: Fri Jan 09, 2015 7:00 pm

Re: Unable to boost past 15psi

Postby Andy05 » Thu Feb 02, 2017 12:12 pm


Project_Dx
Learner Driver
Posts: 17
Joined: Mon Aug 31, 2015 1:15 pm

Re: Unable to boost past 15psi

Postby Project_Dx » Sun Feb 05, 2017 6:29 pm

I've ordered all the silicon hoses to change out from my EBCS. Will see how it goes when I swap them next week

Project_Dx
Learner Driver
Posts: 17
Joined: Mon Aug 31, 2015 1:15 pm

Re: Unable to boost past 15psi

Postby Project_Dx » Wed Aug 02, 2017 5:11 pm

I've done a bit since the last update.

I've replaced all the EBCS hoses, and took it to GotItRex as well to get it looked at. Wawrick said that they couldn't find any physical issues, and the tune is doing what it's supposed to do. He said he has a lot of faith in Michael's tunes (MSR) and the tune looks good. I questioned why the car was not hitting it's target boost, and he couldn't really explain it. He said it may be weather dependant, etc. but i told him that the car used to boost 20psi all the time, I see it on my boost gauge. He did say that the car felt a bit sluggish building up boost also.

I've also replaced the stock BPV with a Forge Motorsport one. I've put in the yellow and blue springs, still doing the same thing.

I've booked him in for another tune, but before I drop another $800 on getting it retuned, was wondering if you guys had any ideas? I would rather much send someone a $50 gift card if you anyone could save me $800... lol

User avatar
PAT555
MY99 WRX Driver
Posts: 1341
Joined: Fri Sep 19, 2003 5:12 pm
Location: Melbourne

Unable to boost past 15psi

Postby PAT555 » Thu Aug 03, 2017 1:54 pm

Eliminate the EBC and test whether you can get it to hit 20 psi. A cheap manual boost controller will do it. This way you will quickly work out if the issue is mechanical i.e with the turbo or its with the EBC and or tune.

Your mad dropping another $800 on a tune.
Also check that the waste gate actuator holds pressure. You could do this with a compressor or a cheap eBay compression kit.
The older I get the slower I drive.

SubWRX
Learner Driver
Posts: 2
Joined: Fri Apr 21, 2017 4:19 am

Re: Unable to boost past 15psi

Postby SubWRX » Sat Aug 05, 2017 9:34 am

I had the same problem, luckily I wasn't charged a fee to put it on the dyno again. My boost gauge was only showing 15.2psi while on the dyno 20psi. As for your car feeling sluggish, your problem may be different to mine. Or just like most of us after a while we need more kW.

Return to “General Technical Talk”

Who is online

Users browsing this forum: No registered users and 17 guests