Page 1 of 1

2002 sti front parking lights not working

Posted: Tue Nov 14, 2017 8:51 pm
by Justinc1981
Hey all,
We just purchased a 2002 sti for a project car and through me checking it out now it’s in the shed that the front parking lights don’t work when u turn the switch on above the steering wheel but the rear ones do - i have changed the bulbs but no difference.

I have also noticed that the HID ballist has been removed and normal bulbs are installed - all low and high beam and indicators are working normally

Any idea what I can check ??
Thanks
Justin

Re: RE: 2002 sti front parking lights not working

Posted: Tue Nov 14, 2017 9:38 pm
by jonoe
Justinc1981 wrote:Hey all,
We just purchased a 2002 sti for a project car and through me checking it out now it’s in the shed that the front parking lights don’t work when u turn the switch on above the steering wheel but the rear ones do - i have changed the bulbs but no difference.

I have also noticed that the HID ballist has been removed and normal bulbs are installed - all low and high beam and indicators are working normally

Any idea what I can check ??
Thanks
Justin
Have you checked your fuses? I assume you checked the wiring / connectors when you changed the bulbs

Sent from my SM-G950F using Tapatalk

Re: 2002 sti front parking lights not working

Posted: Wed Nov 15, 2017 12:48 am
by AJ
The 02 STi didn't come with HID globes in Australia, so your globes are OEM.

Re: RE: 2002 sti front parking lights not working

Posted: Wed Nov 15, 2017 12:38 pm
by Justinc1981
jonoe wrote:
Justinc1981 wrote:Hey all,
We just purchased a 2002 sti for a project car and through me checking it out now it’s in the shed that the front parking lights don’t work when u turn the switch on above the steering wheel but the rear ones do - i have changed the bulbs but no difference.

I have also noticed that the HID ballist has been removed and normal bulbs are installed - all low and high beam and indicators are working normally

Any idea what I can check ??
Thanks
Justin
Have you checked your fuses? I assume you checked the wiring / connectors when you changed the bulbs

Sent from my SM-G950F using Tapatalk


yeh i have had a look at the fuse #5 that i found in the wiring diagram in the service manual and i have tested and confirmed it was all working

Re: 2002 sti front parking lights not working

Posted: Wed Nov 15, 2017 12:41 pm
by Justinc1981
AJ wrote:The 02 STi didn't come with HID globes in Australia, so your globes are OEM.


hi there,
yes it looks like someone as JDM swapped the front headlights as they have the HID leveling plug in the back of the light.
all the lights on the headlight work except the front parking lights and the rear ones work

thanks
Justin