2010 GRB STI hestitation / surging

HelloDorian
Learner Driver
Posts: 2
Joined: Mon Jan 29, 2018 10:25 am

2010 GRB STI hestitation / surging

Postby HelloDorian » Mon Jan 29, 2018 10:58 am

Hi all, 

Just wanting some advice from other owners, particularly those with modified GRBs. 

I'm located in the ACT and the car is modified, everything except the stock block (I know, blasphemy)

I've noticed the car is surging and hesitating more and more as time goes on, it has been running E85 for the last odd 18 months (except in Winter and travelling outside of Canberra), I occasionally put 98 in every other month but have been lacking with that.

What i'm finding the most frustrating about the car right now is when i'm driving softly (most noticeably in 1st gear) the car bunny hops and carries on and revs are all over the place from about 2500 - 3000rpm until i change gear, I first noticed this at the Motorkhana round it SMSP in July last year. I've done logging and it quite clearly shows the revs jumping everywhere.

Another time it surges is just cruising around while daily driving with or without cruise control, on all maps it feels like its hesitating like my foot is off and on the pedal, this happens whenever it wants, 60, 80, 110kmh etc (more noticeable at 100+ kmhs on the highways).

I've read Adam's article about replace the FPR but I don't think it's that, has anyone else got an idea of what could be causing it? I'm assuming it's fuel related. I've narrowed it down to possibly one of the following:
Dirty injectors
Clogged fuel line
Dead / faulty spark plug(s)
Clogged fuel pump filter

I've put some injector cleaner in, and the Nulon E85 performance treatment. It just doesn't hit boost as hard anymore, I can't even remember the last time it was smooth coming on boost. I've replaced the MAF sensor as well hoping it was that, but still happening (Now the car idles from 200-1000rpm even when warm at the lights!

I'm not getting any CEL when I boot it hard, etc just feels like there is something somewhere (anyone in ACT is welcome to come have a look and come for a spin with me to show you!)

Before you all ask, yes I have an aftermarket fuel pump - DW65C and ID1000 injectors, and it's been tuned by MSR with the flex kit, moving forward i'm going to take a bit more of a proactive stance on fuel maintenance by filling up with 98 a bit more regular to give the fuel a clean, but i'm hoping my issue isn't something major, I'm starting to think it could possibly be the Turbo :( further info on the car is it's about to hit 100,000 kms soon and I know the spark plugs will be replace around this time.

Any helpful input would be appreciated! 

Aaron

mv75
WRX STi Driver
Posts: 891
Joined: Sat Dec 27, 2014 9:26 pm
Location: Brisbane Northside.

Re: 2010 GRB STI hestitation / surging

Postby mv75 » Mon Jan 29, 2018 2:00 pm

Vac leak.

User avatar
KuRT12
Impreza 22B Driver
Posts: 1648
Joined: Fri Feb 22, 2013 4:14 pm
Location: Eastern Suburbs, Melbourne

Re: 2010 GRB STI hestitation / surging

Postby KuRT12 » Wed Jan 31, 2018 8:26 am

Has it just started randomly occurring or always been there since tuning?
It could be tune related if there since...

Have you done the 08+ "Stumble Fix" Fuel Mod?
http://www.iwsti.com/forums/diy-mods-an ... x-mod.html

As Mv75 suggested, vac leaks can cause a bit of chaos too, so check under the bonnet to make sure nothing is loose.

What elements are you looking for when logging?
MY '12 SWP WRX STi Spec. R Sedan
Sandown 1:20.48 - Winton 1:35.19 - Wakefield 1:06.84 - Phillip Island 1:44.96 - Broadford 1:03.80 - SMSP Gardner (AD08) : 1:48.05

HelloDorian
Learner Driver
Posts: 2
Joined: Mon Jan 29, 2018 10:25 am

Re: 2010 GRB STI hestitation / surging

Postby HelloDorian » Wed Jan 31, 2018 3:44 pm

Hi guys,

Nah hasn't been doing it since the tune, it was incredibly smooth and linear then. I had my original DW65C die on me nearly 12 months ago, and I've just been noticing it slowly get a little worse, I haven't had a chance to check the fuel filter yet, a new (Subaru OEM filter) was put in when it died, maybe it's just congested.

On the NSW WRX Forum the guys are adamant it's an air leak, unfortunately i won't be home until Friday to give it a thorough once over in the engine bay.

I've read about the FPR issue, if it was happening since it was tuned / modded I would agree it could be the problem but it just seems like it's starting happening over time and getting worse, maybe I just started picking up on it the last few months..

Main logs I've been hunting for was injector cycle duty, revs, speed and fuel pump pressure, all looked okay from my testing, but it definitely jumps on the revs when I need it to, I am hoping it's just a silly air leak I've looked over.

I'll re-connect the wide band and get some AFR logs from that to see if its running lean when it freaks out, could be an air leak if that's the case. Will post back and report when I get around to that

User avatar
KuRT12
Impreza 22B Driver
Posts: 1648
Joined: Fri Feb 22, 2013 4:14 pm
Location: Eastern Suburbs, Melbourne

Re: 2010 GRB STI hestitation / surging

Postby KuRT12 » Thu Feb 01, 2018 3:55 pm

Id be watching for fuel trims around the areas it starts to hunt?
Normally you can diagnose based on learning view fuel trims.
MY '12 SWP WRX STi Spec. R Sedan
Sandown 1:20.48 - Winton 1:35.19 - Wakefield 1:06.84 - Phillip Island 1:44.96 - Broadford 1:03.80 - SMSP Gardner (AD08) : 1:48.05

Return to “General Technical Talk”

Who is online

Users browsing this forum: No registered users and 33 guests